Question Transfert Joomla de distant à local : impossible d'ouvrir (un message d'erreur)

Plus d'informations
24 Jui 2017 16:48 - 24 Jui 2017 16:54 #1 par miqui
Bonjour,
(réédition : pardon, je me suis trompé de thème... est-il possible de le transférer au bon endroit ?)
Je désire transférer mon site distant (chez OVH) en local. Lors du test de lancement je reçois le message suivant :
Warning: session_start(): Failed to read session data: user (path: C:\xampp\tmp) in C:\xampp\htdocs\joomlainicit\libraries\joomla\session\handler\native.php on line 260. Error displaying the error page: Application Instantiation Error: Failed to start the session.
j'ignore l'anglais.... (mal barré !). D'où vient l'erreur ? Dois-je intervenir dans le php.ini à la ligne 260,... et que me faudrait-il faire pour m'en sortir ?
Voici ce que j'ai fait (sous joomla3.7.2. et Xampp dernière version) :
- transfert du contenu du répertoire www du site d'OVH dans Xampp\htdocs\joomlainicit.
- transfert de la BdD (pour ce faire : j'ai du modifier le php.ini car refus pour cause de dossier trop volumineux -[ j'ai porté les valeurs suivantes : - post_max_size=128M - upload_max_filesize=128M - memory_limit=1024M, malgré cela j'ai dû scinder mon BdD en deux parties, cause de temps trop long] !
- J'ai modifié les valeurs code du configuration.php de la sorte :
  • /* Database Settings */
    var $dbtype = 'mysql';
    var $host = 'localhost';
    var $user = 'root';
    var $password = ' ';
    var $db = 'xxx'; // nom de la BdD du phpmyadmin local.
    var $dbprefix = '.....'; // le préfixe de la table de la BdD.
Je patine... Merci par avance pour votre aide.
Dernière édition: 24 Jui 2017 16:54 par miqui. Raison: erreur de thème

Connectez-vous ou Créer un compte pour participer à la conversation.

Plus d'informations
26 Jui 2017 09:03 #2 par serge
utilises akeeba pour faire soit un zip soit un jpa.
puis mets dezippe le .zip et suis la procédure d'installation
ou utilise akeeba quickstart pour faire l'installation du zip ou du jpa
ou utilise akeeba extract wizard pour extraire le jpa et suis la procédure d'install ....

ce sera le plus simple

Connectez-vous ou Créer un compte pour participer à la conversation.

Plus d'informations
26 Jui 2017 17:24 #3 par miqui
Serge.
Merci pour ton attention.
- Si je ne suis pas passé par Akeeba c'est parce-que je n'en conserve pas un bon souvenir... Sans doute est-ce que je l''utilise mal, mais à chaque fois c'est la galère. Jusque là, je réussissais mieux en manuel (même si cela fait quelque temps que je ne l'ai pas pratiqué).
- je viens d'effectuer un nouveau transfert de la BdD. Tout s'est bien passé, d'un seul trait. Seulement, ça ne marche pas. Je reçois l'information : Error displaying the error page: Application Instantiation Error: No database selected
J'ai vérifié configuration php, tout me semble correct... Que signifie No database selected ?
- Je veux bien tenter avec Akeeba, mais avant, je relève dans la BdD une table "si4ad_finder_terms de 17,2 Mio. La BdD fait 38,6 Mio, pour un site d'environ 500 articles. Cela me paraît beaucoup. C'est vraiment la table la plus lourde alors que la table si4ad_content fait quant-à elle 6,7 Mio. Que contient cette table finder_terms ? Est-ce qu'on ne peut pas la réduire et est-ce qu'il ne faudrait pas le faire avant de tenter Akeeba ?
Merci pour ton aide.

Connectez-vous ou Créer un compte pour participer à la conversation.

Plus d'informations
26 Jui 2017 17:56 #4 par starter
Bonjour miqui

www.aide-joomla.fr/tutoriels/administrer...la-avec-akeebabackup

No database selected


Aucune base de données sélectionnée.

Vérifie confiquration.php, tu dois avoir une erreur.

Pas de support en MP sans y être invité.Merci
www.aide-joomla.com
www.soulpin.com

Connectez-vous ou Créer un compte pour participer à la conversation.

Plus d'informations
26 Jui 2017 18:05 #5 par serge
est ce que ton utilisater root a les droits sur la base de données ?
est ce que si tu installes un joomla vierge par exemple cela fonctionne ?

Connectez-vous ou Créer un compte pour participer à la conversation.

Plus d'informations
27 Jui 2017 10:26 - 27 Jui 2017 10:41 #6 par miqui
Bonjour,
Grace à vos remarques, je progresse.
Starter.
En effet il y avait une erreur. je l'ai trouvée en comparant avec le configuration.php d'un site "test" mis en place lors de l'installation de Xampp. J'avais "public $user = 'nomdusite';" au lieu de "public $user = 'root';" !!!...
Ceci dit je n'arrive pas à l'ouvrir le site correctement.
Voici le message d'erreur que je reçois :
[url=
Fichier attaché :
]Message d'erreur[/url]
Par contre, en tentant le backend, et en testant "Accéder à la page d'accueil du site" (image ci-dessous) j'obtiens l'accès au site ; et dans ce frontend j'accède à l'administratif. Mais je n'accède pas directement à l'administratif (configuration, modules, etc...) où j'ai la même réponse que lors de la tentative d'accès au frontend.
[url=
Fichier attaché :
]AccèsAdmin[/url]
Serge,
Pour le root, j'ai honte. Comme quoi on n'est pas toujours suffisamment attentif. Pour ce qui est du Joomla vierge, effectivement j'ai un joomla vierge, installé avec Xampp, et qui fonctionne.

Merci encore.

A la réflexion, mon accès au site dont je parle ci-dessus, ne semble pas être celui du localhost, mais celui de l'hébergeur (adresse URL du site).
Dernière édition: 27 Jui 2017 10:41 par miqui.

Connectez-vous ou Créer un compte pour participer à la conversation.

  • Vous ne pouvez pas: Créer un nouveau sujet.
  • Vous ne pouvez pas: Répondre au sujet.
  • Vous ne pouvez pas: Éditer votre message.
Modérateurs: lavstephxillibittramber91Scottuxsergestarter
Temps de génération de la page : 0.229 secondes