Question Disparition de l'éditeur dans le frontend pour un groupe suite gestion ACL

Plus d'informations
04 Jan 2022 09:32 - 04 Jan 2022 09:37 #1 par thierry84
Bonjour,
J'ai créé un groupe en suivant l'exellent tutoriel ACL Joomla! Configuration des ACL en back-end

Tout me semblait fonctionner à merveille. Le groupe pouvait accéder au backend et ne modifier que ses articles. Dans le frontend également.
Lorsque je réalise ce paramétrage je suis en version Joomla 3.10.3.

Je ne sais pas si cela est lié, mais à partir du moment où je suis passé en version joomla 3.10.4 les membres du groupe, gérés en ACL avec une racine public conforme au tutoriel cité plus haut, n'ont plus eu accès à l'éditeur sur le frontend.
Cela fonctionne dans le back mais pas dans le front.

Je ne trouve pas comment donner les droits à ce groupe pour qu'il puisse avoir un éditeur dans le frontend.
Ils ont accès à l'édition de l'article, mais n'ont pas l'éditeur...

Pouvez-vous, s'il-vous-plaît m'indiquer la marche à suivre ?
L'éditeur par défaut est tinyMCE, si j'utilise JCE l'éditeur n'apparait plus également dans le backend pour ce même groupe.

Je vous remercie beaucoup, et vous souhaite une très bonne année.
 
Dernière édition: 04 Jan 2022 09:37 par thierry84. Raison: une précision supplémentaire importante

Connectez-vous ou Créer un compte pour participer à la conversation.

Plus d'informations
04 Jan 2022 10:56 #2 par serge
bonjour Thierry, et bienvenue
as tu regardé dans ton profil JCE si le groupe était bien coché ?
Les utilisateur(s) suivant ont remercié: thierry84

Connectez-vous ou Créer un compte pour participer à la conversation.

Plus d'informations
04 Jan 2022 12:58 #3 par thierry84
Bonjour,

Merci pour votre réponse.
Il ne s'agit de mon profil, pour moi tout fonctionne correctement. En effet, si je me mets dans le groupe créer avec les droits initiaux "public" là je rencontre le problème de perte de l'éditeur dans le frontend et le backend pour JCE.
Par contre je perds le frontend uniquement avec l'éditeur tinyMCE.

Si je prends mon profil et que dans l'onglet utilisateur / paramètres de bases je mentionne utiliser l'éditeur JCE j'ai toujours le problème résident.

Merci pour votre éclairage.

J'ai utilisé la logique "Refuser jusqu'à Autoriser" cela fonctionnait en Joomla 3.10.3. Depuis, mais je ne sais pas si cela est vraiment lié, depuis mon upgrade en Joomla 3.10.4 et bien je me suis aperçu de ce problème par un retour utilisateur.
J'ai créé ce site bénévolement pour une association de bénévoles.

Bien à vous dans l'attente de votre éclairage.
 

Connectez-vous ou Créer un compte pour participer à la conversation.

Plus d'informations
04 Jan 2022 13:36 #4 par serge
regarde également les droits des groupes dans le plugin tinymce
Les utilisateur(s) suivant ont remercié: thierry84

Connectez-vous ou Créer un compte pour participer à la conversation.

Plus d'informations
04 Jan 2022 13:59 #5 par thierry84
Je viens de mettre le groupe concerné dans Éditeur - TinyMCE en choissant le "set 0".

Everything back to normal. Le groupe dispose de l'éditeur tinyMCE dans le frontend.

Merci beaucoup pour votre excellente réactivité et très belle journée à vous.

Connectez-vous ou Créer un compte pour participer à la conversation.

  • Vous ne pouvez pas: Créer un nouveau sujet.
  • Vous ne pouvez pas: Répondre au sujet.
  • Vous ne pouvez pas: Éditer votre message.
Modérateurs: lavstephtramber91Scottuxsergestarter
Temps de génération de la page : 0.169 secondes