Résolu Joomla 3.10.4, php 8.x, erreur lors de l'accè au site

Plus d'informations
08 Jan 2022 16:30 - 23 Jan 2022 10:12 #1 par carabao
bonjour,
Pour commencer, je vous souhaite mes meilleurs voeux et une très bonne santé pour 2022.
Je ne parviens pas à utiliser php 8.x avec mon site: www.caravane-camping.be, j'obtiens une longue liste de fonctions dépréciées et surtout deux warning
Warning: session_name(): Session name cannot be changed after headers have already been sent in /xxx/xxx/domains/xxxxxx/public_html/libraries/joomla/session/handler/native.php on line 128 Warning: session_cache_limiter(): Session cache limiter cannot be changed after headers have already been sent in /xxx/xxx/domains/xxxxxx/public_html/libraries/joomla/session/handler/native.php on line 235
Error: Failed to start application: Failed to start the session because headers have already been sent by "/xxx/xxx/domains/xxxxxx/public_html/libraries/vendor/joomla/uri/src/UriHelper.php" at line 50.
Si je repasse en php 7.4, les problèmes disparaissent
J'ai listé les différents composants et plugins et sauf erreur de ma part, ils sont compatibles avec php 8.x
  • Akeeba backup
  • jsitemappro
  • breezing form pro
  • contentbuilder
  • kunena
  • phoca gallery
  • phoca download
  • regular lab sourcerer
  • Template-creator
Plugin
up ( up.lomart.fr/ )
+ ceux installés par les composants ci-dessus
J'ai essayé en repassant sous le template protostar, même problème.
Avez-vous une idée de ce qui pourrait coincer ?
Merci
 

Site dédié à la caravane & au camping: www.caravane-camping.be
Dernière édition: 23 Jan 2022 10:12 par carabao.

Connectez-vous ou Créer un compte pour participer à la conversation.

Plus d'informations
23 Jan 2022 10:12 #2 par carabao
Bon, le problème s'est réglé par magie , dira-t-on.

Je suis resté en php 8.0.x et non en php 8.1
J'ai mis l'affichage des défauts à "aucun" et non à "défaut" car il y avait une longue liste de "deprecated".
joomla est passé de 3.10.4 à 3.10.5

Donc pour le moment mon site fonctionne sous joomla 3.10.5, php 8.0 et defaut à "aucun"

Site dédié à la caravane & au camping: www.caravane-camping.be

Connectez-vous ou Créer un compte pour participer à la conversation.

  • Vous ne pouvez pas: Créer un nouveau sujet.
  • Vous ne pouvez pas: Répondre au sujet.
  • Vous ne pouvez pas: Éditer votre message.
Modérateurs: xillibittramber91Scottuxsergestarter
Temps de génération de la page : 0.174 secondes