kunenalogoL'équipe de Kunena annonce la disponibilité de la version 1.6.5 qui est une extension native pour à la fois J! 1.5.23, J! 1.6.5 et J! 1.7.0. Ceci une version de maintenance pour la série 1.6 de Kunena et tous les utilisateurs sont priés de mettre à jour Kunena vers la version 1.6.5. Des sauvegardes et test sont recommandés !

Pour être interopérable sur J! 1.5, J! 1.6 et J! 1.7, la majorité du travail effectué dernièrement s'est fait sur la correction de problèmes importants dans Kunena avant la sortie de la prochaine version majeure : Kunena 2.0, plus tard dans l'année. Les templates tierces écrites pour les précédentes versions de Kunena ne pourrait plus fonctionner avec cette version du fait des changements effectués pour le fonctionnement correct sur J! 1.6/1.7.
Il y a quelques problèmes qui empêchent à K 1.6 de répondre à toutes nos attentes pour tirer complètement parti des fonctionnalités de J! 1.6 ou J! 1.7. Comme pour d'autres extensions de Joomla, le projet Kunena n'est pas seul dans cette situation.

Changements à souligner

Ajout du support Joomla ! 1.7 et amélioration du support de Joomla 1.6.0
  • Amélioration de la prise en charge de sh404SEF (ainsi que la mise à jour du plugin sh404SEF pour Kunena)
  • Laisse les utilisateurs choisir si ils veulent utiliser leur propre lightbox script (corrige de nombreux problèmes avec les templates/modules de Joomla !)
  • Début du support du RTL (pas encore complet)
  • Diverses corrections du CSS
  • Correction de la recherche dans la liste des utilisateurs et correction du comptage d'utilisateurs dans la page publique
  • Correction de divers problèmes dans l'intégration avec CommunityBuilder et JomSocial
  • Correction de bugs divers dans les sondages, dans la modération des utilisateurs, les pièces jointes, RSS, templates etc

Les pré-requis pour la version 1.6.5 ne changent pas :

Attention : Les modules/plugins et templates conçus pour les versions antérieurs de Kunena ne fonctionnent pas sur la version 1.6.x et causent des problèmes, veuillez les désinstallez avant de faire la mise à jour.

Si votre système ne dispose pas des prérequis pour installer kunena 1.6.5, votre forum sera mis hors-ligne, vérifiez que vous disposez des pré-requis suivants :
  • Joomla! 1.5.20+ pour disposer de Mootools 1.2 .4
  • PHP 5.2.3
  • MySQL 5.0
Joomla ! 1.6.3 est requis pour utiliser cette version de Kunena

Pour l'intégration avec les composants tiers vous devez disposer des versions suivantes :
  • Jomsocial 1.6.x
  • Community Builder 1.4.x
  • UddeIm 2.1
  • Alpha User Points 1..5.11
Pour la gestion des ACLs sous Joomla! 1.5, les versions suivantes des composants tiers sont nécessaires :
  • NoixACL 2.0.6 (non recommandé, son support devient obsolète et sera supprimé dans le futur)
  • JXtended Control 1.0.7
  • ArtofUser 1.0.5
Les répertoires suivantes doivent disposer des bonnes permissions en lecture/écriture pour pouvoir installer Kunena :
  • /administrator/components/
  • /components/
  • /media/
  • /plugins/system

Télécharger Kunena 1.6.5

Plus d'informations sur SFK


A propos de l'auteur
Stéphane Bourderiou
Nom: Stéphane Bourderiou
Fondateur des sites Aide-joomla.fr et SFK
Derniers articles de l'auteur

  • Aucun commentaire sur cet article.
Ajouter un commentaire